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ELC 3414: Electronic Design  

 
Lab 2: Op-Amp Limitations 
 

Objective 
 

The objective of this experiment is to examine one of the primary limitations of real operational 
amplifiers.  As we noted in class, the primary limitation of real op-amps is in the limited 
frequency response.  To demonstrate the frequency response limitation we will measure the 
time-bandwidth product of the LM741 op-amp. 
 

Introduction 
 
Because op-amps have very large open loop gains, it is necessary to intentionally limit the 
frequency response of the amplifiers so that unintended oscillations do not occur.  We will learn 
more about op-amp compensation later in the course, but for now we will investigate the price 
to be paid for assuring that our negative feedback circuits will remain stable under all 
conditions. 
 

Procedure 
 
1. Using the 741 integrated circuit and discrete resistors, design a non-inverting amplifier 

having a closed-loop voltage gain Av ≈ 10.  Bias the amplifier with power supply voltages of ± 
15Vdc.  The term “closed-loop” simply means that the amplifier is operated with a feedback 
resistor connected from output to input as we have analyzed in class.  Do the following:  

 
a. Draw a circuit schematic.  (A schematic uses circuit symbols and connects them together 

functionally.  See Figure 1.)   
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Figure 1. a) signal generator (ac source) schematic symbol, b) signal generator block, c) op-amp schematic 

symbol, d) op-amp block. 

b. Draw a circuit wiring diagram.  (A wiring diagram uses blocks to represent actual 
hardware and shows the actual wiring connections made.  Discrete components (e.g. 
resistors, capacitors, & inductors) look the same as in a schematic.  See Figure 1.) 

c. Measure and record the actual resistance of the resistors used in your design. 
d. Calculate the gain expected using the actual resistor values. 
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2. Measure the frequency response of the amplifier and generate a Bode plot from which the 
3-dB bandwidth can be determined.  Recall that a Bode plot is a log-log plot of the 
magnitude of the voltage gain versus frequency.  Your frequency range should extend from 
near dc to at least one decade above the break frequency.  A 1-3-10-frequency sequence 
(e.g. 10, 30, 100, 300, 1000… Hz) is suggested.  Once the break point has been found, 
include additional frequencies to permit accurate determination of the –3 dB value. 

 
Note: Don’t use the FFT feature of the scope, as it is not as accurate as viewing 
the time-domain signal. 
 
3. Repeat the above procedure for voltage gains of Av ≈ 100 and Av ≈ 200.  Plot gain vs. 

frequency for each case (on separate graphs). 
 
4. Estimate the gain-bandwidth product in each of the following ways: 
 

a. Calculate ft = A0CLfBCL for the Av ≈ 10 case, the Av ≈ 100 case, and the Av ≈ 200 case (use 
your measured gain at 100 Hz for A0CL) 

b. Using your charts, extrapolate the –20 dB/decade line until it intersects a gain of 1 
(which is zero dB). 

 

Deliverables 
 

 Submit an informal report containing all of the items described in the above procedure, 
including measured and calculated values (actual resistor values, actual gain, etc), and 
the following Supplement (i.e. one report for both parts). 

 Upload your report to Blackboard by the next lab session (i.e. you have 1 week). 

 Name your report: “ELC3414_Lab_2.doc”  
 
Note:  See the Lab Reports handout for correct format. 
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ELC 3414: Electronic Design 

 

Lab 2 Supplement: PSPICE 
 

Originally by: Chris Anderson 
Modified by: John Miller, 8/19/09 

 

Introduction  
 
This supplement to Lab 2 will take advantage of the some of the key features of computer 
simulation available through the PSPICE program.  Since you have used PSPICE in previous 
courses, the basic operation of the program will not be discussed in detail here.  This lab 
assumes that you are familiar with finding and placing parts, connecting nodes, and performing 
a basic transient analysis.  In this lab we introduce small signal sinusoidal steady-state analysis, 
Fourier spectral analysis, and parametric control of component values for a very basic circuit.   
 
An important application of SPICE simulations is to predict the performance of a circuit over a 
range of conditions, in particular those that include typical variations in component values.  We 
use SPICE to test circuit parameters, determine specifications, and to see if our design will work 
if given the ‘ideal’ parts in the simulation.  While the basic simulations of AC and transient 
analysis are excellent for a first test of circuit performance, we rarely realize the ideal conditions 
that we specify for those simulations.  Resistors, capacitors and inductors have tolerance 
specifications, the beta transistors will vary and the frequency response specifications of an 
integrated circuit may only be given in terms of a “typical” response.  Monte Carlo simulation is 
a valuable tool for exploring the performance of a design over the expected variations in 
component values.   
 
Say that you are an engineer with a high power application project like a communication system 
transmitter.  Your parts will require large voltage and current values.  Each one of the parts for a 
prototype may cost your company $10, $100 or sometimes even $1000 to replace.  As an 
engineer, you will want to make absolutely sure that you specify the correct power tolerances.  
You know that if some of your resistors drop in value at one point in the circuit, the current may 
increase in another part.  If you have a capacitor that will take a maximum of 500 volts and your 
circuit is running at about 480V, a small change in the resistance in the circuit may increase the 
voltage across that capacitor to above its tolerance.   
 
Here is an axiom that you may find humorous.  
 
“If it meets the spec, it will be unavailable for sale 
If it is available for sale, it will be out of stock. 
If it is in stock, it will have a lead time of 10 years 
If the lead time is tomorrow, it will be too expensive 
If it is too expensive, it will meet the spec. 
 
Moral: change the spec to match the cheap part. “ 
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AC Sweep Analysis  
 
 In PSPICE, build a non-inverting amplifier with a gain of 10 using the uA741 part and two 
(or three) resistors.  Name the output node Vout and use a VAC voltage source for an input.  
Specify an input of 0.1 V peak-to-peak and make sure to attach a +/- 15 V source to the rail 
voltage level, V+ and V-. Be sure to ground all the correct points using a GND_ANALOG part.   
Add a voltage “marker” to Vout. 
 
Click on Analysis > Setup 
 
Click on AC Sweep and perform a sweep from 1 kHz to 1 MHz (may have to enter as “1000k”) on 
a log scale with 101 points per decade.  Click ‘OK’ and make sure the checkbox for AC analysis is 
checked and click ‘OK’ again to close the Analysis setup.   
 

Now either click the ‘Simulate’ button  or Click on Analysis > Simulate.  
 
When the Output window pops up, select it and Click on Plot > Axis Settings and make sure the 
X-axis is on a log scale.   
 

Note: if you didn’t add a marker to Vout, you will need to click on the “Add Trace” button  
or go to Trace > Add Trace. 
 
You should see a single line that begins at 1V and begins to fall exponentially, similar to the one 
below.   

 
 

Monte Carlo Analysis 
 
Now we will see how the output changes for random values of resistance.  Return to your circuit 
and double click on each of your resistors.  Find the “Tolerance” parameter and enter “5%” for 
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the tolerance on each of them.  This will allow us to analyze the gain of the circuit including 
random resistor values.   
 
Click on Analysis > Setup and then click on Monte Carlo/ Worst Case.  A Monte Carlo simulation 
performs a statistical analysis with random values for each parameter with a given tolerance.  A 
‘Worst Case’ simulation chooses either the absolute maximum or absolute minimum for the 
tolerance value and performs a simulation on only those values.  We want PSPICE to perform 15 
iterations of random number assignments, so we type in ‘15’ for MC Runs.  We have already run 
an AC Analysis, so we check that box and choose our output variable to be the voltage value at 
the Vout node.  Now we need to choose a Function type.  The various function types are listed 
below.  
 
YMAX – records the largest difference between a normal run and a random run.  
MAX – record the largest values from a random run 
MIN – records the smallest values from a random run 
RISE- records the first occurrence of the signal crossing a high threshold value, which is provided 
by the user 
FALL records the first occurrence of the signal crossing a low threshold value, which is provided 
by the user.  
 
Choose MAX.   
For the MC Output options, you can choose to keep all of the output waveform data, none of it, 
a given number of spaced ones or the first ‘n’ number of them.  The remainder of the 
waveforms will be deleted by PSpice.  Only the waveforms that you keep can be graphed in the 
Probe window.  In our case, we are only doing 15 runs, so keep all of the waveforms.  You 
should see a window like the one below.  Click ‘OK’.  
 

 
 
Make sure that both the Monte Carlo as well as the AC Analysis check boxes are selected and 
simulate the circuit.  Select the probe window and you should see a list called “Available 



ELC 3414  Lab 2 
 

9/3/2013 2:42 PM  p. 6 of 8 

Selections.” Each of these are waveforms that have been stored by the Monte Carlo Analysis.  
All of them should be selected by default, so simply click ‘OK’.  You should produce a plot like 
the one below.   
 

 
 
Click on Edit > Select All, then Edit > Copy. 
 
Open up a new Excel spreadsheet and click paste.  This will insert all of the waveform data 
directly into Excel.  Find the mean and standard deviation for the low frequency gain of the 
amplifier.  Since the gain is constant from 1kHz to about 10kHz, you can use any value here to 
determine the average gain and standard deviation.  Report these values in your lab report.  
 
Include this plot in your lab report.  Choose File > Print Preview to view your waveform with a 
white background and then use the Print screen button on the keyboard to capture the 
waveform and paste it into your document.  (Use the Crop tool in Word to trim it down.)   
 
Click on View > Output File 
 
Scroll down to the bottom and report the absolute maximum percentage deviation from the 
nominal solution in your lab report.  
 

Transient Analysis 
 
Change the source of your Op Amp to a VSIN input with a frequency of 1 kHz, an amplitude of 
0.1 V, and a VOFF value of 0.   
 
Click on Analysis > Setup  
Uncheck Monte Carlo/Worst Case  
Click on Transient … 
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Enter a print step of 50ns, a final time of 1ms, and a center frequency of 1 kHz.  Place a check 
mark next to Fourier Analysis and type “V(Vout)” as the Output variable, just like in the Monte 
Carlo simulation.   
 
Simulate the circuit and look at the output.  You should simply see a large sine wave with a 1V 
peak to peak amplitude.   
 
Click on Trace > Fourier 
 
This is the FFT of your sine wave output.  As expected, you have a single impulse or spike around 
1kHz.  Include this plot in your lab report, using the same technique as above.   
 
Now we will perform another Monte Carlo simulation, only on the transient analysis instead of 
the AC sweep.  Return to your circuit.  
 
Click on Analysis > Setup > Monte Carlo/ Worst Case 
Change the Analysis radio button from “AC” to “Transient”.  Click “OK.”  Make sure that both 
Transient and Monte Carlo/ Worst Case check boxes are check and click “Close.”   
Simulate the circuit again and look at the plot.  You should see a plot like the one below.   
 

 
 
As before, insert the waveform data into Excel and find the maximum standard deviation of the 
circuit.  Report this value in your lab report.  Once again, view the output file and report the 
maximum percentage deviation from the nominal.  Report this value in your lab report.  Include 
this plot in your lab report, using the same technique as above. 
 

Deliverables  
 
Lab Report Plots 

 AC Analysis Monte Carlo 

 Transient Analysis Fourier Transform 

 Transient Analysis Monte Carlo 
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Answer the following questions in your report:  
 

 How does the Monte Carlo analysis work in PSPICE?  

 Why can we get different answers for the standard deviation for a Monte Carlo versus a 
Worst Case analysis?  

 Why would a company want to use a worst case analysis before buying parts for a circuit 
that you have designed?  

 Say that your amplifier was a small part of a power amplification system on a radar. 
Would ¼ watt resistors be large enough to withstand the power requirements for your 
amplifier?  Why or why not? If your communication system had a peak frequency value 
of 50kHz, would your amplifier still be able to deliver a peak voltage of 1 volt?  (Assume 
Vin = 0.1 V maximum.)  

 What would you have to change in your circuit in order to get your circuit ‘in spec’?   
 


