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Wireless Circuits and Systems Laboratory 

Procedure #9 8714 VNA Data Acquisition and Manipulation (using Microsoft 
Excel) 

Contained in this procedure: 
1) Acquiring 1- and 2-port data from the HP8714 and saving to a disk 
2) Importing the measured data into Excel 
3) Generating plots of the measured data within Excel 
4) Formatting the data for use with the ADS circuit simulator 
 
The following procedures are sequential in nature, and thus use common filenames. 

 

1.  HP 8714 Data Acquisition 

The following procedure assumes that all necessary connections and VNA calibrations have been performed, and 
that the number of points (typically 201) and start/stop frequencies are already set.  The steps are specifically 
written for use with the 8714B VNA.  If you are using the 8714C, substitute MEAS for CH in all the steps below.  
Other differences are also noted as required. 

To acquire measurement data and save it to a floppy disk, perform the following steps: 
1. Insert a formatted floppy disk into the disk drive. 

2. Select CH 1. 

3. Press the Format key and select Polar (you may have to select More Format before you see the Polar 
option).  This will allow you to save the data in magnitude and phase format.  If you chose a format such as 
Log, you would only obtain data corresponding to the magnitude (in dB) of your data. 

4. If you will also be saving data from channel 2, select CH 2 and then Format -> Polar.  

5. Press the Save/Recall button.  Select Disk - Internal 3.5” drive.  (If the Fast Recall option is active, turn it 
off.) 

6. Press the Save/Recall button again.  Press the Define Save softkey.  Since you only want to save the data:  
change INST. STATE to OFF, CAL to OFF and DATA to ON. 

7. Now press Save ASCII.  (If you are using the 8714C, you now have to also choose Lotus 123 format). 

8. Press the key to save MEAS 1.  If you are also saving channel 2 data, press the key to save MEAS 2. 

9. At this point you will see a catalog listing of the files on your disk.  From the previous step, you will see a 
file called Trace0.prn which corresponds to the channel 1 data.  If you saved channel 2, you will also see a 
file called Trace1.prn 

 

2.  Importing 8714 Data into Excel 
The following procedure describes how to import the data files Trace0.prn and Trace1.prn into an Excel file.  These 
files correspond to data measured from channel 1 and channel 2 of the 8714, in Polar format, as described in the 
preceding section. 
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1. Start Excel from within Windows 98. 

2. Select Open from the File pull-down menu.  In the pop-up window, change File type to All Files (*.*). 

3. If your data files are on a floppy, change to the a: drive. 

4. Select trace0.prn and click on Open. 

5. Set the Original Data Type to Delimited. 

6. Notice that you can see the first few rows of your data file.  The first row describes which type of 
measurement you saved and the format.  The second row gives the frequency units (e.g., Mhz) and the 
format for the next two columns. 

7. Set Start Import at Row to 3. 

8. Click Next. 

9. In the Delimiters box, click next to Commas. 

10. Click Next. 

11. Set the Column Data Format to General. 

12. Click Finish. 

13. Now save the file as an Excel worksheet.  From the File pull-down menu, click on Save As, set the File 
Type to Microsoft Excel Workbook, and select a filename such as “vna-dat1.xls” 

14. If you acquired your data from the 8714 in Polar format, you should see three columns of data.  The first is 
the frequency (in the units mentioned in step 6 above), the second the magnitude of the scattering 
parameter and the third is the phase of the scattering parameter. 

If you want to combine another data file with this one (e.g., trace1.prn).  
1. Repeat the same steps from above and select a filename such as “vna-dat2.xls”   

2. Now you can copy data from the second file to the first.  Since the frequency units for both files should be 
the same, you only need to copy and paste the second and third columns of data from vna-dat2 to vna-dat1.  
In the vna-dat2 workbook, use the mouse and click on the B column at the top and drag the mouse across 
to highlight both the B and C columns.  From the Edit pull-down menu, select Copy.  Now click on the 
Window pull-down menu and change back to vna-dat1.xls.  Point on the D column at the top and type ctrl-
v (you can also select Paste from the Edit pull-down menu).  You should now have 5 columns of data in 
this modified version of vna-dat1.xls   

3. I suggest using File -> Save As and specify a new Excel workbook file such as “vna-dat3.xls” 

 

3.  Generating Plots within Excel 
 
This procedure explains how to generate plots using Microsoft Excel.  It assumes that you are using either a data file 
consisting of 3 columns (such as vna-dat1.xls) or 5 columns (such as vna-dat3.xls). 
 
 
 

Plots using files with 3 columns of data:   
We will plot the decibel (dB) value of the magnitude column versus frequency. It is assumed that the file contains 
the frequency in column one, magnitude of S11 in column 2, and phase of S11 in column 3. 
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1. Start Excel and open the workbook of interest (e.g., vna-dat1.xls). 

2. Point on the A at the top of the first column and press ctrl-c to copy the data. 

3. Point on the D at the top of the third column and press ctrl-v to paste the data into the new position. 

4. Point in the E1 cell and enter the following:  = 20 * LOG10(B1)  and hit Enter (or Return). 

5. Point in the E1 cell and type ctrl-c.  Now point and drag from E2 down to the bottom of your data file (to 
row 201 if you are using 201 data points) and type ctrl-v. 

6. If you want to preserve the original workbook, use File -> Save As and enter a new name such as “vna-
dat4.xls” 

7. Now point in cell D1 and drag to mouse down to E201 (if using 201 data points) in order to highlight this 
range of cells. 

8. Click on the Insert pull-down menu.  Choose Chart -> On This Sheet and point in some cell such as B204. 

9. In the Pop-Up window, check that the Range is correctly specified (e.g. = $D$1:$E$201) and click Next.  
Select the Line chart type and click Next.  Choose Format 2 and click Next. 

10. Select Data Series in Columns.  Change the counter to use First 1 Columns for Category (X) Axis Label.  
Use First 0 Rows for Legend Text.  Click Next. 

11. Click the box to add a legend.  Enter a chart title (e.g., Example Chart:  vna-dat1), an X-axis label (e.g., 
Frequency (MHZ) and a Y-axis label (e.g., Magnitude (dB)).  Click Finish. 

12. You can now click on the squares around the perimeter of the plot and resize the dimensions. 

13. If you click on the Y-axis along the left a few times you can change some of the settings.  For example, 
you can change the minimum and maximum values, number of gridlines, etc.  You will probably also want 
to change the position where the Category (X) Axis crosses;  setting it to the minimum Y value will place 
the X-axis at the bottom of the plot, as is customary. 

14. Now click on the X-axis a few times under a window pops-up.  First click on the Number tab.  In the 
Category list choose Number and choose 0 under the Format Codes.  This will change the x-axis tick mark 
labels to have no decimal places.  Now choose the Scale Tab and change the Number of Categories 
between Tick Mark Labels to something like 20 and the Number of Categories between Tick Marks to 10. 

15. If you click on the plotted curve a few times you should have a window pop-up which allows you to 
change some additional settings.  (This can be somewhat frustrating to get the proper window up.  First 
click outside the chart a couple times to make sure it is not selected.  Then click on a curve once.  Then 
click on the curve twice quickly.  Then click on the curve twice quickly again.  !)  For example, if you 
click on the Names and Values tab you can change the Name of the curve, which affects what shows up in 
the legend.  In this example, the name was changed to S11. 

 
An example plot is shown below: 



  Procedure #9 

 University of South Florida  p09-000803 4 

Example Plot:  vna-dat4
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Plots using files with 5 columns of data:  
 We will plot the decibel (dB) value of two magnitude columns versus frequency.  It is assumed that the file 
contains the frequency in column one, magnitude of S11 in column 2, phase of S11 in column 3, magnitude of S21 
in column 4 and phase of S21 in column 5. 
 

1. Start Excel and open the workbook of interest (e.g., vna-dat3.xls). 

2. Point on the A at the top of the first column and press ctrl-c to copy the data. 

3. Point on the F at the top of the sixth column and press ctrl-v to paste the data into the new position. 

4. Point in the G1 cell and enter the following:  = 20 * LOG10(B1)  and hit Enter (or Return). 

5. Point in the G1 cell and type ctrl-c.  Now point and drag from G1 down to the bottom of your data file in 
column G (to cell G201 if you are using 201 data points) and type ctrl-v. 

6. Point in the H1 cell and enter the following:  = 20 * LOG10(D1)  and hit Enter (or Return).  Note that this 
column corresponds to the magnitude column for the second measured data set. 

7. Point in the H1 cell and type ctrl-c.  Now point and drag from H1 down to the bottom of your data file in 
column H (to cell H201 if you are using 201 data points) and type ctrl-v. 

8. If you want to preserve the original workbook, use File -> Save As and enter a new name such as “vna-
dat5.xls” 

9. Now point in cell F1 and drag to mouse down to H201 (if using 201 data points) in order to highlight this 
range of cells. 

10. Click on the Insert pull-down menu.  Choose Chart -> On This Sheet and point in some cell such as B204. 

11. In the Pop-Up window, check that the Range is correctly specified (e.g. = $F$1:$H$201) and click Next.  
Select the Line chart type and click Next.  Choose Format 2 and click Next. 

12. Select Data Series in Columns.  Change the counter to use First 1 Columns for Category (X) Axis Label.  
Use First 0 Rows for Legend Text.  Click Next. 

13. Click the box to add a legend.  Enter a chart title (e.g., Example Chart:  vna-dat3), an X-axis label (e.g., 
Frequency (MHZ) and a Y-axis label (e.g., Magnitude (dB)).  Click Finish. 
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14. You can now click on the squares around the perimeter of the plot and resize the dimensions. 

15. If you click on the Y-axis along the left a few times you can change some of the settings.  For example, 
you can change the minimum and maximum values, number of gridlines, etc.  You will probably also want 
to change the position where the Category (X) Axis crosses;  setting it to the minimum Y value will place 
the X-axis at the bottom of the plot, as is customary. 

16. Now click on the X-axis a few times under a window pops-up.  First click on the Number tab.  In the 
Category list choose Number and choose 0 under the Format Codes.  This will change the x-axis tick mark 
labels to have no decimal places.  Now choose the Scale Tab and change the Number of Categories 
between Tick Mark Labels to something like 20 and the Number of Categories between Tick Marks to 10. 

17. If you click on the plotted curve a few times you should have a window pop-up which allows you to 
change some additional settings. (This can be somewhat frustrating to get the proper window up.  First 
click outside the chart a couple times to make sure it is not selected.  Then click on a curve once.  Then 
click on the curve twice quickly.  Then click on the curve twice quickly again.  !)  For example, if you 
click on the Name and Values tab you can change the Name of the curves, which affects what shows up in 
the legend.  In this example, the curves were labelled as S11 and S21. 

An example plot is shown below: 
 

Example chart:  vna-dat5
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4.  Formatting 8714 Data for Use with the ADS Circuit Simulator 
 

One of the options with the ADS circuit simulator is to create a circuit “element” that is described by measured data.  
That is, the simulator relies on measured data located in some file to calculate the characteristics of the element 
when you perform a simulation.  This section explains how you create a data file that has the proper format for use 
with ADS.  The procedure will be explained for 1-port and 2-port data files.  It will be assumed that the data has 
already been acquired from the VNA and imported into an Excel file, following the guidelines described in the first 
two parts of this procedure. 
 
Creating a 1-port data file for ADS:  
 The procedure explains how to transform a file such as vna-dat1.xls into the proper format for ADS.  As described 
in the second part of this document, vna-dat1.xls is a Microsoft Excel workbook with 3 columns of data, 
corresponding to the frequency (assumed here to be in Mhz), the magnitude of S11 and the phase of S11 (in 
degrees). 
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1. Start Excel and open the workbook of interest (e.g., vna-dat1.xls). 

2. Click on the 1 in the first row at the left, to select the entire first row. 

3. From the Insert pull-down menu, click on Insert Rows. 

4. In cell A1, type the following:   # MHZ  S  MA  R  50 and then hit Return or Enter.  Make sure that you 
include a space between # and MHZ.  This line will inform ADS about the contents of the file.  The first 
element (MHZ) corresponds to the frequency units, the second element (S) corresponds to the type of 
parameters contained in the file, the third element (MA) gives the format of the data, which is magnitude 
and angle in this example, and the last elements specify the reference impedance R as 50 Ω. 

5. Click on the A at the top of the first column and drag across to select columns A-C.  Click on the Format 
pull-down menu and select Column -> Width and enter 8.  Click OK. 

6. With columns A-C still selected, click on the Format pull-down menu and select Cells....  Click on the 
Number tab, select Number in the Category column and set the Code to 0.000.  Click OK. 

7. Click on the File pull-down menu and select Save As....  Set the Save File as Type selection to Microsoft 
Excel Workbook.  Specify a name such as vna-da1b.xls and click OK.  This will save a version of your 
file in Excel format in case you have to make changes later. 

8. Now click on the File pull-down menu and select Save As...  Set the Save File as Type selection to Text 
(Tab Delimited).  Specify a name such as vna-dat1.s1p.  Depending on the version of Excel you are 
using, you may have to include quotation marks around the filename, otherwise the name may actually be 
recorded as vna-dat1.s1p.txt.  Also, it is very important to use the .s1p filename extension.  This informs 
ADS that the file corresponds to 1-port S-parameter data. 

9. Click on the File pull-down menu and select Close.  If Excel asks you to save changes before closing, you 
can select No. 

Note:  Before you attempt to use this datafile in ADS, you should place a copy of it in the Data subdirectory of the 
project you want to use it with. 
 
 Creating a 2-port data file for ADS:  
 The procedure explains how to transform a file such as vna-dat3.xls into the proper format for ADS.  As described 
in the second part of this document, vna-dat3.xls is a Microsoft Excel workbook with 5 columns of data, 
corresponding to the frequency (assumed here to be in Mhz), the magnitude of S11, the phase of S11 (in degrees), 
the magnitude of S21 and the phase of S21. 
This procedure is specifically written assuming you have only measured 2 S-parameters of a circuit (S11 and S21) 
and need to use the data to model a 2-port in ADS.  Since ADS requires all 4 S-parameters to be in a 2-port data file, 
we will cheat a little by copying S11 to S22 and S21 to S12.  (For symmetric circuits, there is (theoretically) no 
error introduced by this procedure.  We could also avoid having to do this by measuring all 4 S-parameters with the 
VNA and importing each of them into an Excel file.) 
 

1. Start Excel and open the workbook of interest (e.g., vna-dat3.xls). 

2. Click on the 1 in the first row at the left, to select the entire first row. 

3. From the Insert pull-down menu, click on Insert Rows. 

4. In cell A1, type the following:   # MHZ  S  MA  R  50 and then hit Return or Enter.  This line will inform 
ADS about the contents of the file.  The first element (MHZ) corresponds to the frequency units, the 
second element (S) corresponds to the type of parameters contained in the file, the third element (MA) 
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gives the format of the data, which is magnitude and angle in this example, and the last elements specify 
the reference impedance R as 50 Ω. 

5. Click on the A at the top of the first column and drag across to select columns A-E.  Click on the Format 
pull-down menu and select Column -> Width and enter 8.  Click OK. 

6. With columns A-E still selected, click on the Format pull-down menu and select Cells....  Click on the 
Number tab, select Number in the Category column and set the Code to 0.000.  Click OK. 

7. Click on the D at the top of the fourth column and drag across to select columns D-E.  Type ctrl-c, click on 
the F at the top of the sixth column and type ctrl-v.  This action copies the magnitude and phase of S21 to 
S12. 

8. Click on the B at the top of the second column and drag across to select columns B-C.  Type ctrl-c, click 
on the H at the top of the seventh column and type ctrl-v.  This action copies the magnitude and phase of 
S11 to S22. 

9. Click on the File pull-down menu and select Save As....  Set the Save File as Type selection to Microsoft 
Excel Workbook.  Specify a name such as vna-da3b.xls and click OK.  This will save a version of your 
file in Excel format in case you have to make changes later. 

10. Now click on the File pull-down menu and select Save As...  Set the Save File as Type selection to Text 
(Tab Delimited).  Specify a name such as vna-dat3.s2p.  Depending on the version of Excel you are 
using, you may have to include quotation marks around the filename, otherwise the name may actually be 
recorded as vna-dat3.s2p.txt.  Also, it is very important to use the .s2p filename extension.  This informs 
ADS that the file corresponds to 2-port S-parameter data. 

11. Click on the File pull-down menu and select Close.  If Excel asks you to save changes before closing, you 
can select No. 

Note:  Before you attempt to use this datafile (vna-dat3.s2p) in ADS, you should place a 
copy of it in the Data subdirectory of the project you want to use it with. 
 
 

 
 


