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Wireless Circuits and Systems Laboratory 

Procedure #8 Using the Momentum EM Simulator in ADS 

 

This procedure outlines the use of the electromagnetic simulation tool Momentum, which is bundled into the ADS 
software.  This is a full-wave analysis program that can be used to simulate the performance of arbitrarily shaped, 2 
and 2.5 dimensional microwave circuits.  Its use will be demonstrated in the analysis of a microstrip, short-circuited 
shunt stub.  The procedure will guide you through the main steps involved with the simulation; your work can be 
saved at almost any point in the process, allowing this tutorial to be completed in multiple sessions.  

One of the strengths of this program is its ease-of-use; combining this with its powerful simulation capabilities 
makes it an extremely powerful tool.  Furthermore, this type of simulation capability is nearly indispensable for 
accurate circuit design at higher (> 10 Ghz) microwave frequencies.  At these frequencies parasitics and 
discontinuity effects, which are not always accurately modeled with circuit simulators such as ADS, can become 
significant. 

The program Momentum is started from within the Layout Window in ADS. 

The on-line documentation in ADS is quite good at getting you started, although learning how to use the program 
efficiently and accurately takes practice.  This procedure does not begin to cover all possible options and shortcuts 
for layout and Momentum simulation; if you anticipate future use of Momentum it is definitely worth your while to 
investigate the various windows and menus to a greater extent. 

 

General Description of Geometries 

Momentum will analyze geometries consisting of multiple dielectric and metal layers.  All dielectric layers are 
assumed to be of a given height (or thickness) and of infinite extent in the transverse and longitudinal directions.  
Metal layers can consist of user-defined strips or ground planes that are of infinite extent.  In this way, geometries 
can either be considered as existing on an infinite ground with free space on top, ground planes on the top and 
bottom, or free space on the top and bottom.  Note that it is not necessarily to specify ‘free space’ as having a 
relative dielectric constant of 1 – the dielectric constant can be any value. 

[Note: For slot-line or coplanar geometries the best option is to “define” the slots in the metal, rather than the metal 
strips (in contrast to the approach you take with microstrip, for example).  This approach has the advantage of being 
more computationally efficient, since typically in a coplanar waveguide geometry the slots occupy much less 
physical space than the metal, and thus there are fewer ‘unknowns’ for Momentum to determine.  The disadvantage 
is that you must assume the upper ground planes to be of infinite extent, which is never true in practice.] 

 

Basic Steps in Using Momentum 

The basic steps that are completed to run a Momentum simulation are as follows: 

1.  Create a layout geometry.  Typically, this is done either by importing a file from another drawing package 
(not described here), by creating the geometry directly in the Layout window of ADS, or by “capturing” a 
physical layout of a circuit defined in the ADS schematic window (otherwise known as schematic capture).  If 
your geometry has metal on multiple layers than it must be drawn (or placed) on different layers during the 
layout process.  By default, the layer that is active at startup is usually “cond.” This can be changed using the 
pull-down menus in the Layout window. 

2.  Add ports to your layout.  This is a very important point, and something that requires some care in the case of 
coplanar waveguide (discussed below). 
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3.  Define the substrate.  After you have created the geometry and added ports, you must instruct Momentum how 
the different metal/slot layers in your drawing are “mapped” to different layers of your substrate.   

4.  Solve the substrate.  In this step Momentum performs some initial calculations involving the substrate 
geometry. 

5.  Solve the mesh.  In this step Momentum generates the mesh of the strip or slot geometries. 

6.  Analyze the circuit.  In this step Momentum using the substrate and mesh information and uses the method of 
moments to characterize the circuit or antenna. 

7.  View the results. 

 

Comments on “Meshing” 

As described in the manual, the mesh used to characterize your geometry can be generated from a combination of 
four different steps.  1) You can “seed” the mesh for individual primitives (parts of the geometry) from the Layout 
window.  This is only necessary in very specific cases (refer to documentation).  2) You can specify a mesh for 
individual primitives from the Layout window.  3) You can specify different mesh control for individual layers 
while performing the Process Layer mapping routine and 4) You can specify Global Mesh control that applies to the 
entire geometry.  The order of precedence is as listed here (i.e., Global Mesh control will not override anything 
settings done with the other three methods, etc.).  In most cases only a combination of 3 or 4 is required for accurate 
results. 

 

Comments on Saving Results 

It is possible to save substrate definitions, as well as the results of the substrate calculation, using the Save Substrate 
As command from the Momentum pull-down menu.  This is a nice feature that saves a bit of time if the same 
substrate configuration will be used for different circuit geometries, as is often the case. 

Comments on the Analysis and Adaptive Frequency Sampling 

When analyzing a geometry you can specify a frequency sweep and the number of points to consider between the 
start and stop frequencies.  Momentum also has a very nice feature called Adaptive Frequency Sampling (AFS).  
This is a routine that analyzes the circuit at two specified end point frequencies, and then determines an algorithm to 
generate the S-parameters between the start and stop frequencies using a minimum of sample points. 
 
 
Other Miscellaneous Comments 
 
1.  All geometries should be drawn as polygons (not polylines). 
2.  The Momentum program uses a reference impedance of 50 Ohms for all simulations!  This means that if you 

are using a reference impedance other than 50 Ohms, the calculated S-parameters will not be as you expect.  In 
this case, you have to perform a circuit simulation using ADS after the Momentum simulation and change the 
reference impedance to the value you want to use. 

 
 
A Microstrip Design Example 
 
The circuit layout that will be analyzed is shown in Figure 1.  The coordinates of each vertex are specified in mm.  
This figure shows the “cond” layer, on which the microstrip lines are drawn, and also the square that is drawn on 
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the “pcvia1” layer.  The square will be used to form the via between the signal lines and the microstrip ground 
plane. 
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Figure 1.  Microstrip shunt stub geometry (vertex locations are given in mm).The ground via is indicated by the black rectangle 

near the end of the shunt stub. 

When you draw the geometry in Layout, you will specify two main objects: the microstrip stub and feedlines and 
the via to ground.  The ground plane will be defined when you specify the substrate characteristics. 
 
Procedure 
 
At this point we should discuss what is drawn versus what we are trying to analyze.  In this case, we are interested 
in determining the scattering parameters of a shorted stub in parallel with a 50 Ω line.  However, our model has to 
also include sections of “feed line” that run from the ports to the stub.  These sections of line prevent the reflections 
at the stub (or any other geometry we may simulate) from interfering with the excitation at the port.  The 
interference can result from what are called higher-order modes; these are non-TEM modes which usually only exist 
in the vicinity of discontinuities, and cannot propagate very far since they have a very high attenuation constant.  
These modes are generated as a result of the incident (TEM) mode striking the discontinuity; in circuit simulations, 
their effect is typically modeled using additional capacitance or inductance.  If the ports are very close to the 
discontinuity and the non-TEM modes can propagate to the port, their presence will confuse the simulator and the 
extracted S-parameters will be prone to error.  However, we do not want to make the feed lines excessively long, 
since this increases unnecessarily the amount of circuit that must be simulated, thereby increasing the simulation 
time.  A good rule of thumb is to make the feedlines at least 10 degrees long (about 0.03 wavelengths) at roughly 
the center frequency of interest.  (This means a 0.03-wavelength long line on either side of the discontinuity region, 
if you are simulating a 2-port circuit such as in this example).  In an actual circuit design, it may be necessary to 
verify that the feedline length you have chosen is appropriate for the particular application. 
 
When Momentum begins a simulation, it extends the lengths of the feedlines internally (i.e., in the software only).  
This is necessary for the process of extracting S-parameters from the simulation results.  However, regardless of the 
actual characteristic impedance of the feedlines, you have the ability to specify a desired reference impedance for 
the S-parameters that Momentum calculates and reports.  The reference impedance is determined when you define 
the ports. 
 
I.  Creating the Layout 
 
1) Start ADS and open the Layout window. 
2) Save your layout (i.e., give it a name). 
3) Examine the small boxes at the bottom of the layout window and ensure that the length units are set to mm. 
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4) Click on the Options pull-down menu are select the following: Snap Enabled, Pin Snap, Vertex Snap, and 
Midpoint Snap.  Selecting these options will make it easier to place certain elements, such as the Ports that are 
described in later steps. 

5) Click on the Draw pull-down menu, select Entry Layer and specify Cond.  Until we change the entry layer, all 
objects that we draw will be associated with this “layer”.  (You can also specify the entry layer from the pull-
down menu near the top of the layout window.) 

6) Now we will draw the geometry for the microstrip line.  Instead of drawing the entire circuit as one object, we 
will specify six connected objects.  (This is not necessary, but will provide practice drawing multiple objects.)  
If at any point during the following steps you enter an incorrect vertex, you can delete it using Draw -> 
Undo Vertex. 
a) Object 1: 

i) Click on Draw->Polygon and then Draw->Coordinate entry.  Using the coordinate entry option, all 
vertices will be specified by the x,y coordinates.  In some cases it is easier to use the mouse and click 
on the appropriate location to enter vertices, but this is difficult to do accurately.  (When it happens 
that all vertices can be made to fall on a regular “grid”, the snap-to-grid approach provides a fast way 
to draw objects.  In this case you would simply have to click on the desired grid points and avoid 
having to enter vertices individually.) 

ii) In the Coordinate Entry pop-up window, enter the following (x,y) coordinate pairs.  After entering 
each point, click on Apply.  For the last point you must click on Apply twice to close the polygon.  
(0,0); (3,0); (3,-3), (0,-3), (0,0). 

iii) If you followed the steps properly, you should have a square, filled-in object in the layout and the 
mouse should move around the screen without having a “line” attached to a vertex of the object. 

b) Object 2: 
i) Repeat the previous approach, entering the following (x,y) coordinate pairs:  (3,0); (4.2,0); (4.2,-3); 

(3,-3); (3,0).  Remember to click Apply twice after the last entry. 
c) Object 3: 

i) Repeat the previous approach, entering the following (x,y) coordinate pairs:  (4.2,0); (7.2,0); (7.2,-3); 
(4.2,-3); (4.2,0). 

d) Object 4: 
i) Repeat the previous approach, entering the following (x,y) coordinate pairs:  (3,-3); (4.2,-3); (4.2,-7); 

(3,-7); (3,-3). 
ii) After entering this object, you may not be able to see the entire circuit on the screen.  To correct this, 

click on View pull-down menu and select View All. 
e) Object 5: 

i) Repeat the previous approach, entering the following (x,y) coordinate pairs:  (3,-7); (3,-8.2); (-3.5,-
8.2); (-3.5,-7); (3,-7). 

ii) Select View -> View All. 
f) Object 6: 

i) This time we will use the Vertex Snap approach to define the polygon object. 
ii) Using the mouse, click successively on the 3 vertices of the triangle formed near the lower part of the 

geometry.  Remember that you have to return to click on the starting vertex TWICE to close the 
polygon.  (In other words, you will click on the following vertices:  (3,-7), (4.2,-7), (3,-8.2), (3,-7), (3,-
7).  The starting vertex is actually clicked on a total of three times.) 

g) Close the Coordinate Entry box, hit the “escape” key to end the polygon command and save your design.  
You may have to click on View->Redraw View to refresh the display. 

7) Now we will draw the geometry that will represent the via between the end of the shunt stub and the microstrip 
ground plane. 
a) Click on Draw -> Entry Layer and select PCVIA1. 
b) Click on Draw -> Polygon and Draw -> Coordinate entry. 
c) Enter the following vertex coordinate: (-3.5,-8.2); (-3.5,-7); (-3.3,-7); (-3.3,-8.2); (-3.5,-8.2).  (Hit Apply 

twice after the last vertex.) 
d) Close the coordinate entry pop-up window, hit escape, and save your design. 
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II.  Add Ports 
 
8) Click on the Port button (two to the left of the library (books) button near the top of the layout window.) 
9) Once the Port pop-up window appears, drag it to a location such that you can see both ends of the top 

horizontal strip of the layout. 
10) Position the mouse near the left edge of the top horizontal strip (this edge should run from the vertices (0,0) to 

(0,-3).  If you have Midpoint Snap enabled (from the Options pull-down menu) you should see the mouse 
“skip” to the midpoint of this edge when you get close to it.  (If you have trouble seeing the mouse position 
well, you can click on View -> Zoom Area and use the mouse to draw a box around the area that you want to 
magnify.)  Once the mouse has snapped to the midpoint of the edge, click to place Port 1. 

11) Repeat this process to center Port 2 along the edge that runs from (7.2,0) to (7.2,-3). 
12) Save your design. 
 
 
III.   Define the Substrate 
 
13) Click on the Momentum pull-down menu from the top of the layout window and select Substrate -> 

Create/modify. 
14) By default, you should see a substrate defined by a ground plane, an Alumina layer, and free space.  The only 

change that we have to make is to the middle (Alumina) layer. 
15) Click on the Alumina substrate layer: 

a) Change the thickness to 1.57 mm. 
b) Change the substrate layer name to FR4. 
c) Change the Real part of the permittivity to 4.3 and the loss tangent to 0.022. 
d) Click on Apply 

16) In the substrate pop-up, click on the Metalization Layers tab.  Here, we will “map” layers of the layout to 
locations within the substrate cross-section and also define the “type” of objects that exist on each layer. 
a) Select the cond layer from the Layout Layer section. 
b) In the Substrate Layer section, click on the line that separates FR4 and FreeSpace. 
c) Click on the Strip button and then click on Apply.  (We will leave the Perfect Conductor definition for this 

example.) 
d) Now select the pcvia1 layer from the pull-down list in the Layout Layer section. 
e) In the Substrate Layer section, click on FR4. 
f) Click on the Via button (notice that this is the only choice when you select a layer, rather than a location 

between layers as was done for cond) and Apply. 
g) Click on OK to close the substrate pop-up window. 

17) Click on Moment -> Substrate -> Save As and save the substrate definition. 
18) Save your design. 
 
 
IV.  Solve the Substrate 
 
19) Click on the Momentum pull-down menu and select Substrate -> Precompute Substrate Functions.  In this step, 

Momentum will perform a series of computations that are specific to the substrate definition only, not the 
shapes of the objects in the layout.  As mentioned above, this is useful since you may be able to use the same 
substrate for different shapes of microstrip circuits, but you will not have to re-compute these preliminary 
functions. 

20) Enter a minimum frequency of 0.1 GHz and a maximum frequency of 5 GHz.  Click OK …. And wait. 
21) When the substrate calculations are complete, close the pop-up window, click on Moment -> Substrate -> Save. 
22) Save your design. 
 
NOTE:  After the substrate has been defined you can edit the properties of your ports.  For example, click on 
Momentum -> Port Editor.  Now click on Port 1.  Notice that you can specify any desired value for the (reference) 
impedance of the port.  You can also move the reference planes for the S-parameters toward or away from the 
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current reference location (port position).  In this example, moving the reference planes 3 mm toward the stub 
would allow us to obtain S-parameters for only the stub discontinuity, without including the effects of the 3 mm 
feedlines on either side. 
 
V.  Solve the Mesh 
 
23) Click on the Momentum pull-down menu and select Mesh -> Setup. 
24) In this example, we will use a “global” mesh definition that applies to all objects in the layout.  Make sure the 

Global tab is selected in the mesh pop-up window. 
25) In most cases, the Mesh Frequency should be the highest frequency at which you will perform a simulation.  

Enter 5 GHz. 
26) The Number of Cells per Wavelength (CpW) indicates the number of pieces into which the layout is 

fragmented as a function of electrical size; more cells per wavelength leads to a mesh that is more dense.  
Typically, 20-30 cells per wavelength are required in order to obtain accurate results.  If the number is too 
small, Momentum will not be able to accurately calculate the current distribution on the circuit, leading to poor 
predictions of the scattering parameters.  If the number is “too big” numerical errors can results (the limit of 
“too big” is somewhat hard to define explicitly, as it depends to some extent on the shape of the geometry).  
Note that if you were to specify a mesh frequency of 1 GHz and 30 CpW, the effective number of CpW at 5 
GHz would be five times smaller (since the physical cell size is fixed, but the wavelength is being reduced by a 
factor of 5).  The reverse is also true – by specifying 30 CpW at 5 GHz we will end up with 150 CpW at 1 GHz 
(but remember, more is better, at least to a certain extent).  For this example, specify 25 CpW. 

27) Leave the Arc Facet Angle at the default value of 45 degrees. 
28) Select the Edge Mesh option and specify the Edge Width as 0 mm.  By using Edge Mesh, Momentum will 

create special cells along the edges of the conductors in order to calculate the current distribution more 
accurately.  (On a microstrip line, the current is concentrated at the edges, and having cells along the edge 
improves the simulation results.) 

29) The Transmission Line Mesh option allows you to specifically tailor the mesh design by specifying the number 
of cells in the transverse direction, particularly along straight sections.  In this example we will NOT select this 
option, however. 

30) Select the Thin Layer Overlap extraction option.  While not necessary in this example, it won’t affect the 
results.  You can read more about this option in the on-line documentation. 

31) Click OK to close the mesh controls pop-up window. 
32) Click on Momentum -> Mesh -> Precompute Mesh.  Enter a mesh frequency of 5 GHz and click OK. 
33) When the mesh computation is complete, close the pop-up window and save your design. 
34) Your layout should now resemble Figure 2. 
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Figure 2.  Shunt stub layout in Momentum after completing the mesh computation. 

 
Some discussion regarding the “mesh” may help at this point.  The basic procedure that Momentum uses is to first 
divide the geometry up into smaller pieces; this becomes the mesh.  On each part of the mesh the electric current 
density J is approximated by “basis” functions; each basis function describes the spatial behavior of the current, but 
is weighted by an unknown coefficient.  The simulation problem is solved by forcing the required (electromagnetic) 
boundary conditions of the problem to be satisfied.  This process allows a system of linear equations to be 
generated, which are then solved simultaneously using matrix techniques, in order to determine the unknown 
coefficients of the current basis functions (this technique is known as the Method of Moments).  At this point, the 
distribution of J is known, and the scattering parameters can be computed.  As the geometry is divider into ever-
smaller pieces (creating a finer mesh) the solution for the current becomes more accurate. 
 
VI.  Analyze the Circuit 
 
35) Click on the Momentum pull-down menu and select Simulation -> S-parameters. 
36) Set up the sweep: 

a) Set the sweep type to Adaptive.  Using this option, Momentum will simulate the circuit at the start and stop 
frequencies, an intermediate frequency point (or two) and then perform an adaptive simulation.  Using the 
“adaptive” approach, Momentum will first attempt to predict the results for the entire frequency band, then 
perform a simulation at a given frequency, and compare the results to its prediction.  If the results match its 
prediction, the simulations are stopped.  If the results do not match the prediction, another set of 
predictions and simulation are performed and the process repeats. 

b) Set the start frequency to 0.1 GHz, the stop frequency to 5 GHz, and the sample points limit to 40.  (The 
sample points limit is the largest number of frequency points that will be used for simulation during the 
adaptive process.)  Click on Add to Frequency Plan list (or Update – make sure you only have one 
frequency plan shown). 

c) In the Solution Files box, the name of the data set should match the name of your schematic (by default).  
You can change this if desired. 

d) For this example, the only remaining parameter to set is the Simulation Mode; select Foreground. 
e) Click Simulate …. And Wait.  On a 333 MHz Pentium PC with 128 MB RAM, the simulation took 

approximately 10 minutes. 
 
 

 
VII. Viewing the Results 
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37) When the simulation is complete a data display window should open automatically and include separate plots of 

all four S-parameters. 
38) The name of the data set that is created will be the same as the layout filename, with an “_a” extension.  This 

file will automatically be saved to the Data subdirectory of your project.  If desired, it can be referenced from a 
S*P data element (where * indicates the number of ports) in an ADS schematic by selecting the Filetype as 
Dataset.  Refer to Procedure #3 for details on this process. 

39) For this example, I have double-clicked on the graph of S11, deleted the two parameters automatically entered 
in the graph by Momentum, and added S(1,1) and S(2,1) in dB format.  (I also edited the plot title from the plot 
options tab.)  [The two parameters originally shown on the plot were the calculated S11 at the specific 
frequency points used by Momentum (the markers) and the S11 values calculated by interpolation during the 
adaptive simulation process.  The interpolated data is that which is saved to the *_a dataset.]  The resulting 
graph is shown in Figure 3.  NOTE: depending on the specific steps you follow during any given simulation, 
the results automatically displayed may differ.  The main point is to plot S(1,1) and S(2,1) from the interpolated 
dataset. 

 
 

 
Figure 3.  Momentum simulation results for the microstrip shunt stub. 

 
 
 
Using Air-bridges 
 
When analyzing coplanar waveguide it is often necessary to use air-bridges to provide equalization between the two 
ground planes.  Essentially, in order to do this you need to generate three separate layers in the Layout window: the 
metal or CPW geometry (usually defined as slots) on one layer, the via hole geometry pattern on one layer (line, 
circle, square, etc.) that connects the ground plane and the air-bridge strip, and the air-bridge strip geometry on 
another layer.  When defining the substrate for Momentum you need to specify the usual substrate layer beneath the 
CPW geometry, an “air” substrate which has a thickness equal to the desired air-bridge height, and finally an 
additional air layer for the very top of the geometry (i.e., the boundary to free space, for example).  When 
completing the Process Layer mapping, the CPW geometry is mapped between the lower substrate and middle air 
layer, the via is mapped to the middle air layer, and the air-bridge strip is mapped between the two air layers.  (Note: 
the via layer must also be appropriately mapped to a via process layer such as pcvia1).  The configuration is 
described in the following figure. 
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Transmission line drawn on “cond” layer.

Airbridge strip drawn on “cond2” layer.

Via drawn as square, etc. 
on “via1” layer.

Free-space (open boundary)

Air layer

Substrate (possible open boundary)

Airbridge strip mapped here

Via hole mapped here

Transsmission line mapped here

 
 
 
Comments on Ports for Slot-Specified Coplanar Waveguide 
 
The on-line documentation talks at some length on the topic of using coplanar waveguide ports.  The following 
describes a summary of the approach: 
 
1) Draw the slot version of the geometry on the cond layer in Layout (Figure 4). 
2) Click on Momentum -> Substrate -> Create/modify.  In this example the following is assumed: an open air 

boundary below, an FR4 layer, and an open air (Freespace) boundary above (Figure 5). 
3) Click on the Metallization Layers tab and map the cond layer between the FR4 and Freespace layers and 

specify the type as Slot (Figure 6).  Now close the substrate pop-up window. 
4) Click on the Port button near the top of the Layout window (next to the Library (books) button) and add a port 

at both ends of each slot object (Figure 7). 
5) Click on Momentum -> Port Editor. 

a) Click on Port 1 (upper left) and specify the Port Type as Coplanar.  The polarity should be Normal.  Click 
on Apply. 

b) Click on Port 2 (lower left) and specify the Port Type as Coplanar.  Change the polarity to Reversed.  In 
the Associate with port number box, enter 1.  Click on Apply. 

c) Click on Port 3 (upper right) and specify the Port Type as Coplanar.  The polarity should be Normal.  Click 
on Apply. 

d)  Click on Port 4 (lower right) and specify the Port Type as Coplanar.  Change the polarity to Reversed.  In 
the Associate with port number box, enter 3.  Click on Apply. 

e) Close the Port Editor pop-up window and save your design. 
6) Note that you could also specify port 4 as normal and port 3 as reverse; it depends on the geometry.  The 

polarities should be chosen so that an electric field pointing in the direction of the arrow at port 1 will travel 
through this slot and be pointing in the same direction at port 3 when it arrives at this port. 

 
Once a mesh is generated, Momentum will automatically update the port description on the layout by adding arrows 
to indicate the relative polarity of each port.  An example is given in Figure 8. 
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Figure 4. Slot version of a simple coplanar waveguide line. 

 
 

 
Figure 5. Substrate layer definition for the coplanar waveguide line.  Notice there is an open boundary on the top and bottom in 

this example. 
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Figure 6. Process layer mapping for the coplanar waveguide line.  Notice the slots on the "cond" layer are mapped to the 

location between the FR4 substrate and Freespace, and specified as the 'slot' type. 

 

 
Figure 7. Coplanar waveguide line after placing ports at four positions. 
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Figure 8. Mesh and modified port notation for the coplanar waveguide line. 

 

 

Generating Plots of the Current Distribution 

Momentum provides the option of plotting the current distribution (among other parameters) that was determined 
during the EM simulation.  For example, to plot the electric current distribution after simulating a microstrip layout: 

1) After the simulation is complete, click on Momentum > Post Processing > Visualization in the layout window. 

2) In the pop-up window: 

a) Click on Current > Set Port Solution Weights. 

b) Choose the frequency at which you want the current displayed by setting the corresponding solution weight 
to 1.  Set the solution weight for all unwanted frequencies to zero.  Click on Done. 

c) Click on Current > Plot Currents and choose the desired type of display (e.g., shaded) and the view 
assignment (you can display up to 4 views in the pop-up window simultaneously).  Click on OK. 


