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RF/Microwave Circuits I Laboratory #4 

Coupled-Line Band-Pass Filter Design 

Overview 

In this laboratory you will design and simulate a microstrip coupled-line band-pass filter with a 
center frequency at 3.5 GHz (fc) and a required “stop frequency” (fstop) at 4.0 GHz.  The design 
and topology of the filter are relatively simple, and the primary requirements are that the filter 
must pass a signal at fc with minimal attenuation, and block a signal at fstop with maximum 
attenuation.  

The laboratory involves multiple phases of filter implementation and analysis.  In the first part of 
the assignment you will determine the filter design parameters and then implement an ideal 
transmission line version of the topology.  Next, you will create a microstrip version of the filter.  
The microstrip schematic will be ‘tuned’ (manually or using optimization) to achieve the 
necessary performance.  

The final part of the laboratory assignment requires you to capture the schematic into the layout 
program, and then perform a Momentum simulation.   You will use the ‘visualization’ tools of 
ADS to plot the current density on the microstrip. 

As with previous laboratories, you will make use of information that is contained in several of 
the ADS tutorial procedures.  In comparison to previous laboratory assignments, less detail is 
provided for the step-by-step processes as you should be gaining some level of familiarity with 
the software. 

 

** NOTE ** The examples and plots in the following write-up are based on a substrate with the 
following properties: H = 0.356 mm, Er = 4.3, TanD = 0.022 (i.e., 14 mil FR4).   

You should base your design on the following properties: H = 0.508 mm, Er = 3.6, TanD = 
0.005, T=0.043 mm. 

 

The assignment is organized as follows: 

♦  Determine a topology that exhibits a center frequency at fc and provides at least 30 dB of 
rejection at fstop, using a 0.5 dB ripple Chebyshev design with a reference impedance of 50 
Ω.  The only specification on the filter bandwidth is that it be greater than 2%.  In the 
physical microstrip coupled-line implementation, all gap dimensions must be greater than 50 
microns in order for the filter to be manufactured. 

♦  Create a schematic for the filter design based on ideal (coupled) transmission line elements. 
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♦  Create a second filter schematic, in which the ideal elements are replaced by microstrip 
transmission line sections.  You will use Linecalc to determine the necessary lengths, widths 
and spacings of each section. 

♦  Compare the performance of the two schematics.  Subsequently, modify the microstrip filter 
design to center the pass-band at fc and ensure the attenuation goal at fstop is met. 

♦  Capture the microstrip filter schematic to the layout program and perform a simulation using 
Momentum.  Upon completion, generate a plot of the electric current density. 

  

I. Determine the Filter Geometry and Create the “Ideal” Filter Schematic 
 
You will start by designing the “ideal” filter and testing your design with “ideal transmission 
line” elements to ensure that you have followed the process correctly.  This is a sound practice to 
follow in any design, since you are minimizing the amount of “uncertainty” by conducting a 
sanity check with the ideal elements. 
 
1) Using a 0.5 dB ripple Chebyshev response, determine a filter design that will meet the 

following specifications: 
a) Center frequency at fc 
b) Bandwidth greater than or equal to 2% 
c) Minimum of 30 dB rejection at fstop 
d) NOTES: The amount of out-of-band attenuation at a given frequency-offset from the 

center frequency increases as the filter bandwidth decreases (for a given number of 
sections).  Generally speaking, however, the minimum gap spacing on the coupled-line 
filter sections also will decrease as the filter bandwidth decreases.  While at this point you 
haven’t looked at the microstrip coupled-line dimensions, you will eventually need to 
ensure that no gap spacing is less than 50 microns.  Another way to increase the out-of-
band attenuation at a given frequency-offset is to increase the number of sections in the 
filter.  I strongly suggest, though, that you not use an even order filter (N=2, 4, 6,…) since 
the terminating impedance in a Chebyshev design is no longer 50 Ohms.  
SUGGESTION: start with a minimum reasonable number of sections and experiment 
with different values for the bandwidth (start with a large bandwidth and work your way 
down), checking to see the amount of attenuation you can achieve at fstop.  Increase the 
number of sections only if you cannot achieve the out-of-band attenuation specification 
with a reasonable amount of margin (e.g., 5 dB) while staying within the bounds of 
allowable bandwidths (> 2%). 

e) Summary: for this step in the process, you are trying to determine (a) the order of the 
filter, and (b) the filter bandwidth. 

2) Create a schematic representation of the filter using ideal transmission line components (see 
Figure 1).  In what follows, this schematic is referred to as lab4_ideal_1. 
a) Use “ideal coupled transmission line” (CLIN) elements in the schematic.  These elements 

are found in the T-lines Ideal palette. 
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b) As shown in the figure, you need to enter the even and odd mode impedance for each 
element, the electrical length, and the center frequency (for the electrical length). 

c) Also as shown in the schematic, there will be two “pins” on each element that are not 
connected to any other part. 

d) Attach terminations at each end of the schematic and perform an S-parameter simulation 
from 2-7 GHz. 

e) Once you have verified that your design meets the center frequency and out-of-band 
attenuation specifications (e.g., see Figure 2), proceed to the microstrip implementation in 
the next section. 
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Figure 1.  Partial schematic for band-pass filter using ideal coupled transmission line elements. 

 

 

Figure 2.  Example results for an ideal band-pass filter, with a center frequency of 4.9 GHz. 

 

 



  Laboratory #4 

  T. Weller  EEL4421_6935SoftwareLaboratory4Fall2007.doc 4

II. Create the Microstrip Filter Schematic 
 
1) Use the Linecalc program in ADS to determine the correct lengths and widths for microstrip 

coupled-line sections corresponding to each part of the filter schematic.  Also determine the 
width of a 50 Ω microstrip line.  Set the frequency to fc and use the substrate parameters 
given above (these are also shown in Figure 3).  Note that we are specifying the conductivity 
to be that of copper (5.8e7 S/m). 

 
If any gap dimension for the coupled-line microstrip sections is less than 50 microns, you 
must return to Part I above and determine a different filter design.  Refer to the “notes” 
under step 1 of Part I. 
 
When you are using the “synthesis” routines in Linecalc to determine the dimensions of the 
coupled microstrip line sections, you sometimes have to coerce the program to provide 
“reasonable” dimensions.  For a more detailed discussion on this topic, you should refer to 
ADS Procedure 5 (Using the Linecalc Program in ADS) that is included in the files you 
should have previously downloaded from the course web-site.  Note that this procedure was 
written primarily for use in the Wireless Circuits and Systems Laboratory, so you should 
not pay attention to the particular substrate and transmission line parameters that are 
specified therein. 
 
 
2) Create a schematic for the filter that is based on microstrip elements, herein referred to as 

lab4_microstrip_1 (see Figure 3). 
a) In addition to the filter elements, include 5 mm-long sections of 50 Ω microstrip line at 

each end of the filter. 
b) Attach terminations at each end of the schematic and perform an S-parameter simulation 

from 2-7 GHz. 
c) Once you are satisfied that your filter meets the design specifications (e.g., see Figure 4), 

obtain a hardcopy of the schematic and a hardcopy of the simulated S-parameter results 
(magnitude of S11 and S21 in dB).  Set the minimum value on the y-axis to –60 dB. 

d) As seen in Figure 4, the pass-band insertion loss of the microstrip filter will be higher 
than the ideal design.  The return loss in the pass-band should be approximately 9-10 dB 
or better. 

3) At this point you have an ideal filter design and a microstrip version that should meet the 
design specifications.  Obtain a hardcopy of the simulated S-parameter results for the ideal 
filter.  Plot the magnitude of S11 and S21 in dB, setting the minimum value on the y-axis to –
60 dB.  Also obtain a hardcopy of your ideal filter schematic. 
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Figure 3.  Partial schematic for a band-pass filter using microstrip coupled-line elements. 

 

2.5 3.0 3.5 4.0 4.52.0 5.0

-50

-40

-30

-20

-10

-60

0

freq, GHz

dB
(S

(1
,1

))
dB

(S
(2

,1
))

 

Figure 4.  Example results for a microstrip coupled-line band-pass filter with a center frequency of 4.25 GHz. 
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III. Perform a Momentum Simulation of the Microstrip Filter 
 
1) Use the ‘schematic capture’ feature to automatically generate a layout of the microstrip filter 

(e.g. lab4_microstrip_1). 
a) In the schematic window, select Layout -> Generate/Update Layout.  (Note: if you 

perform this step more than once, you should always open the Layout window and Edit -> 
Delete All to clear the layout before each schematic capture is performed.) 

b) In the Layout window, select and delete the large boxes that represent the “terminations.”  
(If you do not see any large boxes at the termination positions then don’t worry about it.) 
If there are “pins” that remain on the extreme left and/or right sides of the layout (i.e., 
pins that are not connected to the filter geometry) also select and delete these. 

c) Your layout should resemble that shown in Figure 5. 
d) In the layout window, select Momentum>Substrate>Update from schematic.  This step 

should automatically transfer the MSUB information from the schematic into the 
Momentum files (if you select Substrate>Create/Modify, the definition should resemble 
that given in Figure 6 and Figure 7. 

e) Select Momentum>Substrate>Save As… and use the default name that is provided. 
f) Add ports to each end of the layout: 

i) Select Options -> Midpoint Snap 
ii) Zoom in on the left-hand side of the filter. 
iii) Add a “port” to the mid-point of the 50 Ohm line on the left-hand side of the filter.  

Refer to Figure 8. 
iv) Repeat these steps to add a port on the right-hand side of the filter. 

g) Select Momentum -> Port Editor.  Click on each port and make certain they are specified 
as shown in Figure 9 and click Apply.  (Make sure to do this for both ports.) 

h) Select Momentum>Mesh>Setup controls.  Enter the parameters shown in Figure 10. 
i) Select Momentum>Mesh>Precompute mesh.  The generated mesh should resemble that 

shown in Figure 11. 
j) Obtain a hardcopy of your layout with the mesh shown. 

 
 

 
Figure 5.  Partial layout of the microstrip filter created using the schematic capture tool. 

 
2) Perform the Momentum simulation and generate a plot of the calculated S-parameters and of 

the electric current density. 
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a) Select Momentum>Simulation>Simulate circuit.  Set the parameters as shown in Figure 
12 and perform the simulation. 

b) When the simulation is complete, a display will automatically open with plots of the S-
parameters.  If you already had a display open from the previous schematic window 
simulation, the results will simply be updated with the Momentum results. 

 
When the Momentum simulation was performed, two separate output data sets were created.  
One was named lab4_microstrip_1.dds (assuming this was the saved name of your layout 
file) and the second was named lab4_microstrip_1_a.dds.  The first dataset contains S-
parameter results for the particular frequencies that were used by Momentum during the 
simulation – this file will actually overwrite the output file from the schematic simulation if 
the names of the schematic and layout files are the same.  However, the more important 
dataset in this case is the second one (with the _a extension) as this contains S-parameters at 
more frequency points, created during the “adaptive” sweep. 
 
c) In the display window, create (or modify the) plots to ensure that the data being plotted is 

from the lab4_microstrip_1_a dataset.  Generate a plot from this dataset that includes the 
magnitude of S11 and S21, with the minimum value on the y-axis set to –60 dB.  (If you 
double-click on the plot, you will be able to select the dataset from the pull-down menu in 
the middle of the pop-up window.)  

d) Sample results are shown in Figure 13.   
e) Obtain a hardcopy of the plots. 

3) Finally, use the visualization capability of Momentum to generate a plot of the electric 
current density on the microstrip filter. 
a) From the layout window, select Momentum>Post-Process>Visualization. 
b) From the visualization window, select Current>Set Port Solution Weights from the menu 

near the top of the window.  Verify that the default settings are as shown in Figure 14.  
(The port solution weight should be 1 at Port 1 at fc GHz, specifying that the excitation 
should be applied only at this port and at this frequency.) 

c) Now select Current>Plot Currents and use the “shaded” option.  You should obtain a plot 
similar to that shown in Figure 15. 

d) Experiment with plotting the current densities as the excitation frequency changes (by 
modifying the port solution weights).  For each change, specify a different “view” from 
the Plot Currents window, else you will have multiple plots being generated on top of 
each other.  You can also click on the Display Properties button on the left-hand side of 
the main visualization window, and create an “animation” of the current. Select 2 GHz as 
one of your plot frequencies. 
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Figure 6.  Substrate definition used for the Momentum simulation. 

 

Figure 7.  Substrate definition (mapping of metallization layers) used in the Momentum simulation. 

 



  Laboratory #4 

  T. Weller  EEL4421_6935SoftwareLaboratory4Fall2007.doc 9

 

Figure 8.  Port added to the left-hand side of the filter. 

 

 

Figure 9.  Port property definition. 
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Figure 10.  Mesh definition used in the Momentum simulation. 

 

Figure 11.  Layout of microstrip filter showing the Momentum mesh. 

 



  Laboratory #4 

  T. Weller  EEL4421_6935SoftwareLaboratory4Fall2007.doc 11

 

Figure 12.  Simulation controls used in the Momentum analysis of the microstrip filter. In this lab you should simulate from 2-7 
GHz using an “adaptive” pass and also specify a single frequency at fc. 

 

2.5 3.0 3.5 4.0 4.52.0 5.0

-50

-40

-30

-20

-10

-60

0

freq, GHz

dB
(S

(3
,3

))
dB

(S
(4

,3
))

 

Figure 13.  S-parameters for a microstrip filter as calculated by Momentum. Notice that the return loss in the passband has 
degraded (it is <10 dB in some parts of the pass-band) 
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Figure 14.  Port solution weights used to generate the plot of the electric current density. 

 

Figure 15.  Representative plot of the electric current density at fc. 
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Laboratory Reporting Requirements 
 
1) Your report should include the following: 

a) Printouts of the following: 

i) The ideal filter schematic and the simulated S11, S21 plot. 

ii) The microstrip filter schematic and the simulated S11, S21 plot. 

iii) The microstrip filter layout and the Momentum simulation results (S11, S21 plot). 

b) A short explanation of the following: 

i) Create a table that includes the insertion loss and return loss at fc and fstop for the 
ideal filter, the microstrip circuit simulation, and the microstrip Momentum 
simulation. 

ii) Describe the difference in the electric current density plots at 2 GHz and ~3.5 GHz.  
With an excitation at Port 1 for a frequency in the pass-band of the filter, do you see a 
high current density appearing at Port 2? (Explain why or why not.) 

iii) Explain what you believe to be the dominant loss factor in the filter.  (You can 
investigate this topic using the circuit schematic.) 


