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RF/Microwave Circuits I Laboratory #3 

Microstrip Quadrature Coupler Design and Analysis 

Overview 

In this laboratory you will design and analyze a microstrip quadrature coupler.  The first version 
of the coupler will be assembled using ideal transmission line models and will therefore exhibit 
the ‘ideal’ quadrature coupler response.  This schematic will be used as the benchmark, against 
which you will compare the response of a ‘real’ coupler comprised of microstrip transmission 
line models.  One of the main objectives is to modify the microstrip configuration so that its 
response matches the ideal response as closely as possible.  You will also examine some basic 
properties of the coupler. 

As with previous laboratories, you will make use of information that is contained in several of 
the ADS tutorial procedures. 

The assignment is organized as follows: 

♦  Create a schematic that represents a quadrature coupler comprised of ideal transmission line 
segments.  This schematic will use ‘ports’ (versus terminations) so that it can be referenced 
from a higher-level schematic. 

♦  Create a higher-level schematic that references the ideal quadrature coupler schematic.  At 
this point you will perform a few basic analyses to study the properties of the coupler. 

♦  Use the Linecalc transmission line calculator tool within ADS to determine dimensions for 
microstrip lines needed in the ‘real’ quadrature coupler schematic (refer to Procedure #5 
Using the Linecalc Program in ADS). 

♦  Create a schematic that represents a quadrature coupler comprised of microstrip transmission 
line segments.  This schematic will use ‘ports’ (versus terminations) so that it can be 
referenced from the higher-level schematic. 

♦  Return to the higher-level schematic and add a reference to the microstrip quadrature coupler 
schematic.  Modify the dimensions of the microstrip line segments such that the ‘real’ 
coupler response matches that of the ‘ideal’ coupler as closely as possible.  Circuit 
optimization will be used in this step. 
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I. Generate the Ideal Transmission Line Quadrature Coupler 
 
1) Start ADS and create a new schematic, herein called quad_ideal_1_4port.dsn 
2) Generate a schematic for the quadrature coupler using ideal transmission lines, assuming a 

center frequency of 2.5 GHz (see Figure 1). 
a) Add a variables (Var) block to the schematic (the button for this is located to the left of 

the Library (books) button near the top of the schematic window).  When you specify the 
parameters for the ideal transmission line segments you will have to provide the 
impedance, electrical length and reference frequency for the electrical length.  Enter the 
five parameters as shown in Figure 1, except fc should be 2.5 GHz. 

b) In order to access the library models for ideal transmission line segments, click on the 
Component Palette pull-down menu and select Tlines-Ideal. 
i) Select the Ideal 2-Terminal Transmission Line element – this should be the button on 

the top, left-hand side of the list on the left-hand side of the schematic window. 
ii) Place transmission line elements in your schematic that represent the four branches of 

the quadrature coupler, specifying the parameters for each element as shown in the 
figure. 

c) Add PORTS at the proper locations and connect all elements using the wire (line) tool.  
When placing the ports, follow the numbering/position scheme shown in Figure 1 to 
ensure consistency with the remaining sections of this assignment. 

d) Save your design. 
 

 

Figure 1.  Circuit schematic of the ideal transmission line quadrature coupler (quad_ideal_1_4port.dsn). 

II. Generate the Higher-Level Schematic 
 
1) Create a new (higher-level) schematic, herein called quad_main_1.dsn 
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a) Create a reference to the ideal transmission line coupler schematic (quad_ideal_1_4port) 
using the approach outlined in Procedure #2 (see Figure 2). 

b) Attach 50 Ω TERMINATIONS to the four ports of the network.  For clarity, you should 
add ports sequentially such that the port numbers match the pin numbers on the network 
(this ensures that Term1 in the higher-level schematic corresponds to Port 1 in the lower 
level schematic).  If the pin numbers do not appear in your schematic, click on Options > 
Preferences > Pin/Tee and select the box to turn pin number ‘visibility’ on. 

c) Add an S-parameter simulation block and specify the Start/Stop/Step as 1 GHz, 8 GHz 
and 0.05 GHz. 

2) Analyses 
a) Simulate the circuit: 

i) Generate a plot of S11, S21, S31 and S41 in dB.  Set the minimum on the y-axis to –
40 dB and the maximum to 0 dB. 

ii) Determine the bandwidth over which S21 and S31 are greater than or equal to –4 dB.  
(Clearly indicate a numerical value for the bandwidth on your plot.) 

iii) Determine the bandwidth over which the isolation is greater than or equal to 20 dB.  
(Clearly indicate a numerical value for the bandwidth on your plot.) 

iv) [Note: in the graphic display window, you can click on Marker>New and then select a 
trace onto which a marker is added.  Once the marker is in place, you can move it 
along the curve by dragging it with the mouse.  As you move the marker the x- and y- 
values are displayed in real-time.  After you are finished with a move, a text box 
linked to the marker is updated.   The text box can be re-positioned with the mouse 
for easier viewing.] 

v) Add a plot to the display window and plot the phase of S21 and S31 in degrees. 
vi) Obtain a hard-copy printout of the graphics display window. 
vii) Determine the two frequencies between which the phase difference between S21 and 

S31 is within 90 +/- 5 degrees.  Note that you will have to account for a 360-degree 
correction, since the phase is automatically plotted on a +180 to –180 degree range. 
(Clearly indicate a numerical value for the two frequencies on your plot.) 

b) Disconnect the termination from port 4 (i.e. Term4) and deactivate the termination (do 
not delete it). 

c) In place of the termination, attach a grounded 50 Ω resistor to the open port. 
d) Re-simulate the circuit: 

i) Since you have effectively reduced the 4-port to a 3-port, you will have to edit the two 
plots in the graphic display window and delete the S41 parameters from each plot. 

ii) Describe the differences in the remaining S-parameters, in comparison to the 
simulation in which four terminations were in place (i.e. how do S11, S21 and S31 
change in magnitude and phase?). 

e) Edit the resistor in the schematic window and change to value to zero Ω. 
f) Re-simulate the circuit: 

i) Does the circuit still function as a quadrature coupler near the center frequency?  How 
about away from the center frequency?  How do these results confirm or contradict 
the presence of isolation between port 1 and port 4? 

g) Before continuing, return to the schematic window, delete the resistor and re-connect the 
Term4 element such that the schematic returns to the form shown in Figure 2.  You 
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should also re-simulate, and then return to the graphics display window and add S41 back 
to each plot. 

h) If you intend to stop at this point and continue later, use the File>Save As command to 
save the current contents of the graphic display window.  It can later be recalled and you 
will not have to recreate the existing plots. 

 

 

Figure 2.  Higher-level schematic that references the ideal transmission line coupler schematic. 

 

III. Generate the Microstrip Quadrature Coupler 
 
1) Create a new schematic, herein called quad_real_1_4port. 
2) Place a microstrip substrate element into the schematic, and specify the parameters as shown 

in Figure 3. 
3) Invoke the Linecalc transmission line calculator by clicking on Tools>Linecalc>Start 

Linecalc. 
a) A detailed example of using Linecalc is given in Procedure #5. 
b) You should set the Component to MLIN, enter the appropriate substrate parameters and 

set the Frequency to 2.5 GHz.  Your Linecalc pop-up window should appear as shown in 
Figure 4. 

c) Determine the following dimensions: 
i) The width of a 50 Ω microstrip line 
ii) The physical length of a 50 Ω microstrip line that is 90 degrees long at 2.5 GHz 
iii)  The width of a 35.3 Ω microstrip line 
iv) The physical length of a 35.3 Ω microstrip line that is 90 degrees long at 2.5 GHz 
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v) [Note: To follow these steps you should set the proper ZO and E_EFF parameters and 
use the ‘synthesis’ option to find the physical dimensions.  Make sure your units are 
correct.] 

d) You can save the Linecalc setup for use in later laboratories using the File>Save As 
command. 

4) Close Linecalc and return to the schematic window. 
5) Add a variables (Var) block to the microstrip quadrature coupler schematic.  Specify the 

following variables: 
a) W_tb – the width of the microstrip lines on the top and bottom branches of the coupler 
b) W_lr – the width of the microstrip lines on the left and right branches of the coupler 
c) W_50 – the width of a 50 Ω microstrip line. 
d) L_tb – the length of the microstrip lines on the top and bottom branches 
e) L_lr – the length of the microstrip lines on the left and right branches 
f) NOTE: all variables except W_50 should be enabled as optimizable (using the 

Continuous, Min/Max approach).  The nominal values should be those determined using 
Linecalc.  Set the minimum and maximum values at –20% and +20% of the nominal 
values, respectively.  With this approach, we have used ‘good’ starting values for all the 
elements and provided what is hopefully a reasonable range in which the parameters can 
vary. 

g) NOTE: the value for W_50 should equal the nominal value for W_lr (since both are 
ideally 50 Ω lines). 

6) Create the quadrature coupler layout using microstrip library elements (see Figure 5). 
a) The schematic includes microstrip lines on the top and bottom branches with widths 

W_tb and lengths L_tb, and lines on the left and right branches with widths W_lr and 
lengths L_lr. 

b) In order to model the junctions at each corner you need to include the MTEE element 
models (microstrip tee-junction).  Exercise care when specifying the widths at the three 
ports of the tee-junctions, so that they correctly map to the line widths connected at each 
of its port.  The tee-junction port that leads out of the circuit should have a width of 
W_50 (since we’re assuming connections to a 50 Ω reference impedance). 

7) Add PORTS to the network, and save the design. 
8) Obtain a hard-copy printout of your schematic. 
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Figure 3.  Microstrip substrate definition used in the microstrip quadrature coupler. 

 
 

 
Figure 4.  Linecalc window used to determine necessary microstrip line geometry.  The “Freq” parameter should be specified 

according to your specific design. 
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Figure 5.  Schematic of the microstrip quadrature coupler (quad_real_1_4port.dsn). 

 
 

III. Analyze and Optimize the Microstrip Quadrature Coupler 
 
1) Return to the higher-level schematic. 
2) Add a reference to the microstrip quadrature coupler schematic (quad_real_1_4port).  Add 

50Ω TERMINATIONS to each port, being sure to follow the proper numbering scheme.  In 
this case, you want Term5 to correspond to Port 1 in the lower level schematic, Term6 to 
correspond to Port 2, and so forth. 

3) Perform an S-parameter simulation: 
a) Add two plots to the display window that you previously generated when analyzing the 

ideal coupler.  In the first plot, display S55, S65, S75 and S85 in dB format, setting the y-
axis minimum to –40 dB and the maximum to 0 dB.  In the second plot, display the phase 
of the same S-parameters. 

b) Record the values of the magnitude and phase of these 4 S-parameters at 2.5 GHz.  These 
values become the starting point for your design --- hopefully you can now modify the 
circuit such that its response matches that of the ideal coupler. 

c) Now add one additional plot to the display window.  In this plot you will create a graph 
that shows the magnitude of the difference between the S-parameters of the ideal coupler 
and the microstrip coupler. 
i) Select the Rectangular Plot button and drag a new plot into the window. 
ii) When the Plot Traces & Attributes window pops up, click on the Advanced button. 
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iii) In the blank area, enter the following: mag(S(1,1)-S(5,5)).  Click on okay. 
iv) Enter the remaining three expressions that are shown in Figure 6. 
v) Record the values of the 4 magnitude differences at 2.5 GHz. 

d) Obtain a hard-copy printout of the display window. 
4) Return to the higher-level schematic 

a) Add optimization goals that will try to force the differences between S11, S21, S31 and 
S41 of the ideal coupler, and the corresponding parameters of the microstrip version 
(S55, S65, S75 and S85), to be zero.  Refer to Figure 7. 

b) Use the techniques developed in Laboratory #1 to improve/optimize the response of the 
microstrip quadrature coupler.  The performance specifications that we are most 
interested in are (referring to performance near the design frequency): 
i) The return loss – typically you would like to see at least 25 dB at the center frequency. 
ii) The amplitude match between S21 and S31 – typically you want each of these 

parameters to be as close to –3 dB as possible (e.g. –3 +/- 0.5 dB or so is usually 
desirable) 

iii) The phase difference between S21 and S31 – typically you want a phase difference in 
the range of 90 +/- 5 degrees or better. 

iv) The isolation – typically you would like to see at least 25 dB, hopefully more. 
v) In this exercise we can use the difference between S-parameters of the ideal 

coupler and those of the microstrip coupler as our best guide.  Here the goal will 
be to make all 4 differences less than 0.05 (this is a very good match).  

c) Here are some things to keep in mind: 
i) Remember to “Update Optimization Values” after completing an optimization run. 
ii) It is probably unrealistic to think that, by adjusting the dimensions of the microstrip 

version, you can make the response match that of the ideal coupler over a broad 
frequency range.  Instead, try to improve the microstrip coupler performance over a 
frequency range that is centered upon your design frequency.  The more bandwidth 
you can obtain, the better – but try to achieve the desired performance (differences 
less than 0.05) over at least f_center +/- 1 GHz.  (You can reduce the frequency range 
in the S-parameter simulation control block SP1 during optimization, update the 
optimization values, disable the optimization block, and then re-set the frequency 
range to create a plot over the full 8 GHz bandwidth when you are satisfied with your 
results.) 

iii) If, after performing an optimization run, you do not obtain the desired results – look at 
the variables in the quad_real_1_4port schematic and see if the optimizer is pushing 
any of them toward the minimum/maximum limits that you set.  If so, expand the 
possible range of values by adjusting the limits. 

iv) If you really want to dig into this problem, you could try different modifications to the 
microstrip version.  For example, instead of having a microstrip line of constant width 
on the top/bottom branches, you could break the lines into multiple segments with 
different widths (including the appropriate microstrip step---MSTEP---elements in the 
schematic).  But you should NOT disrupt the geometrical symmetry of the coupler. 
[Note: this approach is NOT necessary to achieve the desired performance 
specifications mentioned above, but it’s always an option.] 

d) When you are satisfied with the performance of your ‘optimized’ microstrip coupler: 
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i) Obtain a hard-copy printout of the final schematic (quad_real_1_4port) showing the 
optimized parameter values 

ii) Obtain a hard-copy printout of the S-parameters of the optimized coupler and the plot 
showing the 4 S-parameter magnitude differences over frequency (to 8 GHz). 

iii) Go into your quad_real_1_4port schematic and disable the optimization on the 
variables.  This will “fix” the final values, in case you use the schematic in a later 
design. 

 
 

 

Figure 6.  Expressions used to calculate the magnitude of the difference between the S-parameters of the ideal and microstrip 
couplers. 

 
 

 
Figure 7.  Optimization goals used to improve the response of the microstrip quadrature coupler. 
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Laboratory Reporting Requirements 
 
1) Your report should include the following: 

a) Printout of the graphics display window showing the S-parameters of the ideal 
transmission line coupler with the information about the 90-degree phase difference 
frequency range for S21 and S31.  Include identifying information on the printout. 

b) Answers to the questions in Section II. 

c) Printout of the microstrip quadrature coupler schematic prior to performing any design 
modifications.  Include identifying information on the printout. 

d) Printout of the S-parameters of the microstrip quadrature coupler, prior to performing any 
design modifications, along with the 4 S-parameter magnitude differences.  Include 
identifying information on the printout. 

e) Values for S55, S65, S75 and S85 at 2.5 GHz of the microstrip coupler, prior to 
performing any design modifications, along with the value of the 4 S-parameter 
magnitude differences, at 2.5 GHz. 

f) Printout of the microstrip quadrature coupler schematic after optimization.  Include 
identifying information on the printout. 

g) Printout of the S-parameters of the microstrip quadrature coupler, after optimization, 
along with the 4 S-parameter magnitude differences.    Include identifying information on 
the printout. 

h) Brief discussion of the following: 

i) The process you found worked best for optimizing the response of the microstrip 
coupler. 

ii) Before any optimization of the microstrip coupler was performed, what trends did you 
notice in the 4 S-parameter magnitude differences?  What might be the cause of these 
trend(s)? 


